insane bbclass: add '8' (.la references workdir) to list of fatal errors
[vuplus_openembedded] / packages / linux / linux-openmoko_2.6.22.5.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION = "Linux 2.6.x kernel for FIC SmartPhones shipping w/ OpenMoko"
5 VANILLA_VERSION = "2.6.22"
6 KERNEL_RELEASE = "2.6.22.5"
7
8 # If you use a rc, you will need to use this:
9 #PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}-moko11+svnr${SRCREV}"
10
11 PV = "${KERNEL_RELEASE}-moko11+svnr${SRCREV}"
12 PR = "r13"
13
14 KERNEL_IMAGETYPE = "uImage"
15 UBOOT_ENTRYPOINT = "30008000"
16
17 ##############################################################
18 # source and patches
19 #
20 SRCREV_FORMAT = "patches"
21
22 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
23            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1 \
24                svn://svn.openmoko.org/trunk/src/target/kernel;module=patches;proto=http \
25            file://fix-EVIOCGRAB-semantics-2.6.22.5.patch;patch=1 \
26            file://fix-gta01-flowcontrol2-2.6.22.5.patch;patch=1 \
27            file://gta02-sound.patch;patch=1 \
28            file://soc-core-suspend.patch;patch=1 \
29            file://iis-suspend.patch;patch=1 \
30            file://s3c24xx-pcm-suspend.patch;patch=1 \
31            file://gta-vibro-pwm-suspend.patch;patch=1 \
32            file://defconfig-${KERNEL_RELEASE}"
33
34 S = "${WORKDIR}/linux-${VANILLA_VERSION}"
35
36 ##############################################################
37 # kernel image resides on a seperate flash partition (for now)
38 #
39 ALLOW_EMPTY = "1"
40
41 COMPATIBLE_HOST = "arm.*-linux"
42 COMPATIBLE_MACHINE = 'fic-gta01|fic-gta02'
43
44 CMDLINE = "unused -- bootloader passes ATAG list"
45
46 ###############################################################
47 # module configs specific to this kernel
48 #
49
50 # usb
51 module_autoload_ohci-hcd = "ohci-hcd"
52 module_autoload_hci_usb = "hci_usb"
53 module_autoload_g_ether = "g_ether"
54 # audio
55 module_autoload_snd-soc-neo1973-wm8753 = "snd-soc-neo1973-wm8753"
56 module_autoload_snd-soc-neo1973-gta02-wm8753 = "snd-soc-neo1973-gta02-wm8753"
57 module_autoload_snd-pcm-oss = "snd-pcm-oss"
58 module_autoload_snd-mixer-oss = "snd-mixer-oss"
59
60 # sd/mmc
61 module_autoload_s3cmci = "s3cmci"
62
63 do_prepatch() {
64         mv ${WORKDIR}/patches ${S}/patches && cd ${S} && quilt push -av
65         mv patches patches.openmoko
66         mv .pc .pc.old
67         mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
68 }
69
70 addtask prepatch after do_unpack before do_patch
71