Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / linux / linux-openmoko-devel_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
5
6 DEFAULT_PREFERENCE = "-1"
7
8 KERNEL_RELEASE = "2.6.28"
9 KERNEL_VERSION = "${KERNEL_RELEASE}"
10
11 OEV = "oe1"
12 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
13 PR = "r3"
14
15 SRC_URI = "\
16   git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
17   file://openwrt-ledtrig-netdev.patch;patch=1 \
18   file://defconfig-oe.patch \
19 "
20 S = "${WORKDIR}/git"
21
22 do_configure_prepend() {
23         install -m 644 ./arch/arm/configs/gta02_packaging_defconfig ${WORKDIR}/defconfig-oe
24         cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
25 }
26