Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / linux / linux-openmoko-2.6.28_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE = "2.6.28"
7 KERNEL_VERSION = "${KERNEL_RELEASE}"
8
9 OEV = "oe1"
10 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
11 PR = "r3"
12
13 SRC_URI = "\
14   git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
15   file://openwrt-ledtrig-netdev.patch;patch=1 \
16   file://0001-MERGE-via-pending-tracking-hist-subject-usb-gadget-r.patch;patch=1 \
17   file://0002-MERGE-via-pending-tracking-hist-subject-usb-gadget-f.patch;patch=1 \
18   file://0003-consider-alrm-enable-in-pcf50633_rtc_set_alarm.patch;patch=1 \
19   file://0004-manage-RTC-alarm-pending-flag-of-PCF50633.patch;patch=1 \
20   file://0005-debug-glamo-allow-slower-memory-bus.patch.patch;patch=1 \
21   file://0006-Subject-fix_glamo_xrandr_bug.patch.patch;patch=1 \
22   file://0007-Subject-glamo_fix_improper_xrandr_geometry_setting.patch;patch=1 \
23   file://0008-Send-pen-up-events-faster-side-effect-improve-illu.patch;patch=1 \
24   file://defconfig-oe.patch \
25 "
26 S = "${WORKDIR}/git"
27
28 do_configure_prepend() {
29         install -m 644 ./arch/arm/configs/gta02-packaging-defconfig ${WORKDIR}/defconfig-oe
30         cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
31 }
32