KERNEL_IMAGETYPE cleanup
[vuplus_openembedded] / packages / linux / linux-magicbox_2.6.18.6.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for Magicbox ver 1.1 and 2.0 router boards"
3 LICENSE = "GPL"
4 PR = "r2"
5 DEPENDS = "u-boot"
6
7 COMPATIBLE_MACHINE = "magicbox"
8
9 KERNEL_CCSUFFIX = "-3.4.4"
10
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
12           file://000-fix-makefile.patch;patch=1 \
13           file://001-magicbox-board-2.6.18.patch;patch=1 \
14           file://002-magicbox-mtd-map-2.6.18.patch;patch=1 \
15           file://010-load-ramdisk-even-if-rootdev-equals-ramdisk.patch;patch=1 \
16           file://magicbox2-ide-cf_2.6.18.patch;patch=1 \
17           file://squashfs3.1-patch;patch=1 \
18           file://squashfs-lzma-support.patch;patch=1 \
19           file://kernel-2.6.18-layer7-2.6.patch;patch=1 \
20           file://config-2.6.18-magicbox2\
21 "
22
23
24 S = "${WORKDIR}/linux-${PV}"
25
26 inherit kernel
27
28
29 FILES_kernel-image = "/boot/zImage.elf"
30
31 export OS = "Linux"
32 ARCH = "ppc"
33 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
34
35
36
37
38 do_configure_prepend() {
39         install -m 0644 ${WORKDIR}/config-2.6.18-magicbox2 ${S}/.config
40 }
41
42
43 do_stage_append () {
44 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
45
46        install -d ${STAGING_KERNEL_DIR}/arch/
47        cp -a arch/ppc ${STAGING_KERNEL_DIR}/arch/
48        cp -a arch/powerpc ${STAGING_KERNEL_DIR}/arch/
49
50        cp -a include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
51        cp -a include/asm-ppc ${STAGING_KERNEL_DIR}/include/
52 }
53
54
55
56 do_install_append () {
57         install -d  ${DEPLOY_DIR}/images
58         install -m 0755 arch/ppc/boot/images/zImage.elf ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
59         install -m 0755 vmlinux ${DEPLOY_DIR}/images/
60         powerpc-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S ${DEPLOY_DIR}/images/vmlinux ${DEPLOY_DIR}/images/linux.bin
61         gzip -f -9 ${DEPLOY_DIR}/images/linux.bin
62         mkimage -A ppc -O linux -T kernel -C gzip -a 0 -e 0 -n "ppc405"+${PV} -d ${DEPLOY_DIR}/images/linux.bin.gz ${DEPLOY_DIR}/images/uImage-${PV}-${MACHINE}-${DATETIME}.bin        
63         rm ${DEPLOY_DIR}/images/vmlinux
64         rm ${DEPLOY_DIR}/images/linux.bin.gz
65
66
67 }
68
69
70 pkg_postinst_kernel () {
71         true
72 }
73
74 pkg_postrm_kernel () {
75         true
76 }
77
78