merge of '45fb4fa94d52a65c3a3fa636c6122139173dfa8d'
[vuplus_openembedded] / packages / linux / linux-h1940_2.6.11-bk1-h1940.bb
1 DESCRIPTION = "Linux kernel for h1940 devices."
2 SECTION = "kernel"
3 LICENSE = "GPL"
4
5 COMPATIBLE_HOST = "arm.*-linux"
6
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
8            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/old/patch-2.6.11-bk1.gz;patch=1 \
9            http://rtpnet.nerim.net/ipaq/2.6.11-bk1/2.6.11-bk1-h1940.patch;patch=1 \
10            file://defconfig"
11
12 S = "${WORKDIR}/linux-2.6.11"
13
14 inherit kernel
15
16 do_configure() {
17         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
18         yes '' | oe_runmake oldconfig
19 }