Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / linux / linux-geodelx_2.6.11.bb
1 # Linux kernel OE build file for the AMD Geode GX5535/LX5536
2 # Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 COMPATIBLE_MACHINE = "geodelx"
6
7 DESCRIPTION = "Linux kernel for the AMD Geode GX5535/LX5536"
8 HOMEPAGE = "http://www.amd.com/embedded"
9 LICENSE = "GPL"
10
11 FILE_PR = "r0"
12 AMD_DRIVER_VERSION = "02.03.0100"
13 AMD_DRIVER_LABEL = "Patches_Linux2.6.11_Common_${AMD_DRIVER_VERSION}"
14
15 KV = "${PV}"
16
17 S = "${WORKDIR}/linux-${KV}"
18
19 inherit kernel
20
21 ARCH = "i386"
22
23 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
24         http://www.amd.com/files/connectivitysolutions/geode/geode_lx/${AMD_DRIVER_LABEL}.patch;patch=1 \
25         file://defconfig"
26
27 do_configure_prepend() {
28
29         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
30 }