Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / linux / linux-dm7020.bb
1 DESCRIPTION = "Linux kernel for Dreambox DM7020"
2 LICENSE = "GPL"
3 PN = "linux-dm7020"
4 PV = "2.6.9"
5 PR = "r4"
6
7 # -r1 is the patch revision - it's not related to this package's PR
8 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.9.tar.bz2 \
9         http://sources.dreamboxupdate.com/download/kernel-patches/linuxppc-2.6.9-r1.diff.bz2;patch=1;pnum=1 \
10         http://sources.dreamboxupdate.com/download/kernel-patches/linuxppc-2.6.9-dream-s8.diff.bz2;patch=1;pnum=1"
11
12 S = "${WORKDIR}/linux-2.6.9"
13
14 inherit kernel
15
16 FILES_kernel-image = "/boot/zImage.elf /boot/autoexec.bat"
17
18 export OS = "Linux"
19 ARCH = "ppc"
20 KERNEL_IMAGETYPE = "zImage"
21 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
22
23 do_configure_prepend() {
24         oe_machinstall -m 0644 ${S}/arch/ppc/configs/dm7020_defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
25         oe_runmake oldconfig
26 }
27
28 do_install_append () {
29         install -d ${D}/boot
30         install -m 0755 arch/ppc/boot/images/zImage.elf ${D}/boot/zImage.elf
31         echo "/flash/bootlogo.elf" > ${D}/boot/autoexec.bat
32         echo "/flash/zImage.elf" >> ${D}/boot/autoexec.bat
33 }
34
35 pkg_postinst_kernel () {
36         true
37 }
38
39 pkg_postrm_kernel () {
40         true
41 }
42