Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / linux / linux-dm500plus.bb
1 DESCRIPTION = "Linux kernel for Dreambox DM500PLUS"
2 LICENSE = "GPL"
3 PN = "linux-dm500plus"
4 PV = "2.6.12"
5 PR = "r1"
6
7 # -rX is the patch revision - it's not related to this package's PR
8 SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.12.tar.bz2 \
9         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dream-ppc-r5.patch.bz2;patch=1;pnum=1"
10
11 S = "${WORKDIR}/linux-2.6.12"
12
13 inherit kernel
14
15 FILES_kernel-image = "/boot/zImage.elf /boot/autoexec.bat"
16
17 export OS = "Linux"
18 ARCH = "ppc"
19 KERNEL_IMAGETYPE = "zImage"
20 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
21
22 do_configure_prepend() {
23         oe_machinstall -m 0644 ${S}/arch/ppc/configs/dm500plus_defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
24         oe_runmake oldconfig
25 }
26
27 do_install_append () {
28         install -d ${D}/boot
29         install -m 0755 arch/ppc/boot/images/zImage.elf ${D}/boot/zImage.elf
30         echo "/flash/bootlogo.elf" > ${D}/boot/autoexec.bat
31         echo "/flash/zImage.elf" >> ${D}/boot/autoexec.bat
32 }
33
34 pkg_postinst_kernel () {
35         true
36 }
37
38 pkg_postrm_kernel () {
39         true
40 }
41