merge of '49e39c42b944dda8eed607394e1849029b9f527f'
[vuplus_openembedded] / packages / linux / linux-dht-walnut_2.6.20.bb
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 require linux.inc
4
5 DESCRIPTION = "Linux kernel for DHT-Walnut (ppc)  machine"
6
7 PR = "r4"
8 DEPENDS = "u-boot"
9
10 COMPATIBLE_MACHINE = "dht-walnut"
11
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
13            file://defconfig"
14
15 S = "${WORKDIR}/linux-${PV}"
16
17 FILES_kernel-image = "/boot/zImage.elf"
18
19 export OS = "Linux"
20 ARCH = "ppc"
21 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
22
23 do_stage_append () {
24 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
25
26        install -d ${STAGING_KERNEL_DIR}/arch/
27        cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
28        cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
29
30        cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
31        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
32 }
33
34 do_install_append () {
35         install -d  ${DEPLOY_DIR_IMAGE}
36         install -m 0755 arch/ppc/boot/images/zImage.elf \ 
37                 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
38         install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
39 }
40
41
42 pkg_postinst_kernel () {
43         true
44 }
45
46 pkg_postrm_kernel () {
47         true
48 }
49
50
51
52