Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / linux / ep93xx-kernel_2.6.17+2.6.18-rc1.bb
1 DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 PR = "r1"
5
6 COMPATIBLE_MACHINE = "ep93xx"
7
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.bz2 \
9            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc1.bz2;patch=1 \
10            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/old/patch-2.6.18-rc1-git9.bz2;patch=1 \
11            http://www.wantstofly.org/~buytenh/ep93xx/derevo20.diff;pnum=1;patch=1 \
12            file://defconfig \
13                    "
14
15 S = "${WORKDIR}/linux-2.6.17"
16
17 inherit kernel
18
19
20
21
22 do_configure() {
23         rm -f ${S}/.config
24
25         if [ ! -e ${WORKDIR}/defconfig ]; then
26                 die "No default configuration for ${MACHINE} available."
27         fi
28
29
30         if [ "${TARGET_OS}" == "linux-gnueabi" -o  "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
31                 echo "CONFIG_AEABI=y"                   >> ${S}/.config
32                 echo "CONFIG_OABI_COMPAT=y"             >> ${S}/.config
33         else
34                 echo "# CONFIG_AEABI is not set"        >> ${S}/.config
35                 echo "# CONFIG_OABI_COMPAT is not set"  >> ${S}/.config
36         fi
37
38         sed -e '/CONFIG_AEABI/d' \
39             -e '/CONFIG_OABI_COMPAT=/d' \
40             '${WORKDIR}/defconfig' >>'${S}/.config'
41
42         yes '' | oe_runmake oldconfig
43
44
45 }