openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / libxslt / libxslt_1.1.22.bb
1 DESCRIPTION = "GNOME XSLT library"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "libxml2 (>=2.6.27)"
5 LICENSE = "MIT"
6
7 SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
8 S = "${WORKDIR}/libxslt-${PV}"
9
10 inherit autotools pkgconfig
11
12 EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
13
14 # Something is wrong inside configure.ac, so we need to resort to sed in this stage :(
15 # Koen - 20080305
16 do_compile_append() {
17         sed -i -e s:-L${STAGING_LIBDIR}::g  libexslt.pc
18         sed -i -e s:-L${STAGING_LIBDIR}::g  libxslt.pc
19
20
21 do_stage () {
22         autotools_stage_all
23 }
24
25 PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
26
27 FILES_${PN}-dev += "${bindir}/xslt-config"
28 FILES_${PN}-utils += "${bindir}"