Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libxosd / libxosd_svn.bb
1 DESCRIPTION = "A library for displaying a TV-like on-screen display in X."
2 SECTION = "libs/x11"
3 DEPENDS = "virtual/libx11 libxext"
4 LICENSE = "LGPL"
5 PV = "2.2.15+svnr${SRCREV}"
6 FILE_PR = "r5"
7
8 SRC_URI = "svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https \
9            file://autofoo.patch;patch=1 \
10            file://use-sane-default-font.patch;patch=1"
11
12 S = "${WORKDIR}/current"
13
14 inherit autotools binconfig
15
16 do_stage() {
17         autotools_stage_all
18 }
19
20 PACKAGES =+ "${PN}-examples-dbg ${PN}-examples"
21 FILES_${PN}-examples = "${bindir}/osd_cat"
22 FILES_${PN}-examples-dbg += "${bindir}/.debug/"
23 FILES_${PN}-dev += "${bindir}/xosd-config"
24 FILES_${PN} = "${libdir}/libxosd.so.*"