Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libxine / libxine-fb_1.0.bb
1 DESCRIPTION = "libxine is a multimedia library with support for many common audio and video formats \
2 This version is configured for the usage with framebuffer based environments"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "zlib libogg tremor libmad libmodplug libpng"
7 PROVIDES = "virtual/libxine"
8 FILE_PR = "r1"
9
10 inherit autotools pkgconfig gettext
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/xine/xine-lib-${PV}.tar.gz \
13         file://cpu-${PV}.patch;patch=1 \
14         file://configure-${PV}.patch;patch=1 \
15         file://demuxogg.patch;patch=1 \
16         file://fix-syntax.patch;patch=1 \
17         file://libxine-cut-memusage.patch;patch=1 \
18         file://libxine-ffmpeg-enable-arm.patch;patch=1 \
19         file://libxine-libvorbis.patch;patch=1 \
20         file://libxine-tremor-autoconf.patch;patch=1 \
21         file://mpegvideo-static-inlinine.patch;patch=1 \
22         file://libxine-arm-configure.patch;patch=1 \
23         file://no-caca.patch;patch=1 \
24     file://libxine-gcc4.patch;patch=1"
25 S = "${WORKDIR}/xine-lib-${PV}"
26
27 SOV = "1.0.7"
28
29 EXTRA_OECONF="-with-zlib-path=${STAGING_EXECPREFIXDIR} \
30         --with-vorbis-prefix=${STAGING_EXECPREFIXDIR} \
31         --disable-oggtest \
32         --with-ogg-prefix=${STAGING_EXECPREFIXDIR} \
33         --disable-altivec --disable-vis --disable-mlib \
34         --enable-shared --disable-static \
35         --disable-fb --disable-alsa --disable-vcd \
36         --disable-asf --disable-faad --disable-iconv \
37         --disable-aalib  --disable-aalibtest        \
38         --without-v4l --without-arts --without-sdl \
39         --disable-dxr3 --without-xv --without-xvmc \
40         --without-xxmc --without-Xshm --without-x "
41
42 do_compile() {
43         oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
44 }
45
46 do_install() {
47         oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
48 }
49
50 HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h            \
51         src/xine-engine/xine_internal.h  src/xine-engine/xine_plugin.h    \
52         src/xine-utils/xine_buffer.h     src/xine-engine/video_out.h      \
53         src/xine-engine/buffer.h         src/xine-engine/vo_scale.h       \
54         src/xine-engine/configfile.h     src/xine-utils/attributes.h      \
55         src/xine-engine/info_helper.h    src/xine-engine/scratch.h        \
56         src/xine-engine/audio_decoder.h  src/input/input_plugin.h         \
57         src/xine-engine/spu_decoder.h    src/xine-engine/audio_out.h      \
58         src/xine-engine/io_helper.h      src/xine-engine/video_decoder.h  \
59         src/xine-engine/broadcaster.h    src/xine-engine/metronom.h       \
60         src/xine-utils/xmllexer.h        src/xine-engine/osd.h            \
61         src/xine-engine/video_overlay.h  src/xine-utils/xmlparser.h       \
62         src/xine-utils/compat.h          src/xine-engine/plugin_catalog.h \
63         src/xine-engine/post.h           src/demuxers/demux.h             \
64         src/xine-engine/resample.h       lib/os_types.h                   \
65         src/xine-engine/refcounter.h"
66
67 do_stage() {
68         install -d ${STAGING_INCDIR}/xine
69
70         install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
71
72         for file in ${HEADERS}; do
73                 cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
74         done
75
76         oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
77 }
78
79 PACKAGES_DYNAMIC = "libxine-plugin-* libxine-font-*"
80
81 python populate_packages_prepend () {
82         plugindir = bb.data.expand('${libdir}/xine/plugins/1.0.0', d)
83         do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
84
85         postdir = bb.data.expand('${libdir}/xine/plugins/1.0.0/post', d)
86         do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
87
88         fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
89         do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
90 }
91
92 # Omit the annoying xine-config in ${bindir}
93 FILES_${PN}="${libdir}/*.so*"
94
95 # And include it in the dev package
96 FILES_${PN}-dev += " ${bindir}"
97