Qtopia/X11: Install the right Qtopia XSession start script as well
[vuplus_openembedded] / packages / libtool / libtool_1.5.24.bb
1 DEFAULT_PREFERENCE = "-1"
2
3 DESCRIPTION = "Generic library support script \
4 This is GNU libtool, a generic library support script.  Libtool hides \
5 the complexity of generating special library types (such as shared \
6 libraries) behind a consistent interface."
7 HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
8 LICENSE = "GPL"
9 SECTION = "devel"
10 PR = "r1"
11
12 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
13            file://autotools.patch;patch=1 \
14            file://uclibc.patch;patch=1 \
15            file://never-ever-do-rpath.patch;patch=1" 
16
17 S = "${WORKDIR}/libtool-${PV}"
18
19 PACKAGES = "${PN}-dbg libltdl libltdl-dev ${PN}"
20 FILES_${PN} += "${datadir}/aclocal*"
21 FILES_libltdl = "${libdir}/libltdl.so.*"
22 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
23
24 inherit autotools
25
26 EXTRA_AUTORECONF = "--exclude=libtoolize"
27
28 do_configure () {
29         find ${S} -name acinclude.m4 | for m4 in `cat`; do
30                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
31         done
32         autotools_do_configure
33 }
34
35 do_stage () {
36         oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
37         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
38 }