merge
[vuplus_openembedded] / packages / libtool / libtool_1.5.10.bb
1 DESCRIPTION = "Generic library support script \
2 This is GNU libtool, a generic library support script.  Libtool hides \
3 the complexity of generating special library types (such as shared \
4 libraries) behind a consistent interface."
5 HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
6 LICENSE = "GPL"
7 SECTION = "devel"
8 PR = "r5"
9
10 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
11            file://autotools.patch;patch=1 \
12            file://uclibc.patch;patch=1 \
13            file://3figures.patch;patch=1"
14 S = "${WORKDIR}/libtool-${PV}"
15
16 PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
17 FILES_${PN} += "${datadir}/aclocal*"
18 FILES_libltdl = "${libdir}/libltdl.so.*"
19 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
20 FILES_libltdl-dbg += "${libdir}/.debug/"
21
22 inherit autotools
23
24 EXTRA_AUTORECONF = "--exclude=libtoolize"
25
26 do_configure () {
27         find ${S} -name acinclude.m4 | for m4 in `cat`; do
28                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
29         done
30         autotools_do_configure
31 }
32
33 do_stage () {
34         oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
35         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
36 }