Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / libssh / libssh_0.2.bb
1 # Released under the MIT license (see COPYING.MIT for the terms)
2
3 DESCRIPTION = "The SSH library is a C library to authenticate in a \
4 simple manner to one or more SSH servers. The goal of this project \
5 is to provide a library much simpler to use than OpenSSHs one. It \
6 includes SFTP support, and a sample SSH client is provided."
7
8 HOMEPAGE = "http://0xbadc0de.be/wiki/libssh:libssh"
9 LICENSE = "LGPL"
10 SECTION = "libs"
11 DEPENDS = "openssl"
12 SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
13            file://libssh_libdir_fix.patch;patch=1 \
14           "
15 inherit autotools
16
17 EXTRA_OECONF = "--cache-file=${S}/config.cache"
18 do_compile () {
19         oenote make "$@"
20         make "$@" || die "oe_runmake failed"
21 }
22 do_stage () {
23         install -d ${STAGING_INCDIR}/libssh
24         for i in crypto.h libssh.h sftp.h ssh2.h; do
25                 install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
26         done
27         oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
28 }