merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / libsdl / libsdl-mixer_1.2.8.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libmikmod"
5 LICENSE = "LGPL"
6
7 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
8 S = "${WORKDIR}/SDL_mixer-${PV}"
9
10 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
11
12 inherit autotools
13
14 EXTRA_OECONF = "--disable-music-mp3"
15 # although we build smpeg... need to find out how
16 # to deal with optional dependencies
17
18 do_stage() {
19         autotools_stage_all
20 }
21