Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / librsync / librsync_0.9.7.bb
1 DESCRIPTION = "librsync is a free software library that implements the rsync \
2 remote-delta algorithm. This algorithm allows efficient remote updates of a \
3 file, without requiring the old and new versions to both be present at the \
4 sending end."
5 HOMEPAGE = "http://librsync.sourceforge.net/"
6 SECTION = "libs"
7 LICENSE = "LGPL"
8 PR = "r0"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/librsync/librsync-${PV}.tar.gz"
11
12 inherit autotools pkgconfig
13
14 EXTRA_OECONF = "--disable-build-docs --enable-shared "
15
16 do_stage() {
17     oe_libinstall -a -so -C .libs librsync ${STAGING_LIBDIR}
18     install -d ${STAGING_INCDIR}/
19     for i in librsync.h librsync-config.h
20     do
21         install -m 0644 ${S}/$i ${STAGING_INCDIR}/$i
22     done
23 }