Merge nslu2-linux@nslu2-linux.bkbits.net:openembedded
[vuplus_openembedded] / packages / libogg / libogg_1.0.bb
1 SECTION = "libs"
2 DESCRIPTION = "libogg is the bitstream and framing library \
3 for the Ogg project. It provides functions which are \
4 necessary to codec libraries like libvorbis."
5 LICENSE = "BSD"
6 PR = "r1"
7
8 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
9
10 inherit autotools pkgconfig
11
12 do_stage () {
13         oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
14
15         install -d ${STAGING_INCDIR}/ogg
16         (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
17         install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
18 }