Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libnet / libnet_1.0.2a.bb
1 DESCRIPTION = "Libnet is a collection of routines to help with \
2 the construction and handling of network packets. It provides a \
3 portable framework for low-level network packet shaping, \
4 handling, and injection."
5 SECTION = "libs/network"
6 LICENSE = "GPL"
7 PR = "r1"
8
9 # There are major API changes beween libnet v1.0 and libnet v1.1
10 PROVIDES = "libnet-1.0"
11
12 #SRC_URI = "http://www.packetfactory.net/libnet/dist/deprecated/libnet-${PV}.tar.gz \
13 SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet0/libnet0_${PV}.orig.tar.gz \
14            file://configure.patch;patch=1 \
15            file://configure.uclibc.patch;patch=1 \
16            file://configure_x86-64-host.patch;patch=1 \
17            "
18 S = "${WORKDIR}/libnet-${PV}.orig"
19
20 inherit autotools
21
22 CPPFLAGS_prepend = "-I${S}/libnet/include -DHAVE_PF_PACKET "
23 EXTRA_OEMAKE = "'LIB_PREFIX=${libdir}/' 'MAN_PREFIX=${mandir}/' \
24                 'BIN_PREFIX=${bindir}/' 'INC_PREFIX=${includedir}/'"
25
26 #FIXME: (fixing this would remove the need for configure.uclibc.patch above)
27 do_configure() {
28         oe_runconf
29 }
30
31 do_stage() {
32         install -m 0755 libnet-config ${STAGING_BINDIR_CROSS}/
33         install -m 0644 include/libnet.h ${STAGING_INCDIR}/
34         install -d ${STAGING_INCDIR}/libnet
35         install -m 0644 include/libnet/libnet-headers.h ${STAGING_INCDIR}/libnet/
36         install -m 0644 include/libnet/libnet-functions.h ${STAGING_INCDIR}/libnet/
37         install -m 0644 include/libnet/libnet-structures.h ${STAGING_INCDIR}/libnet/
38         install -m 0644 include/libnet/libnet-macros.h ${STAGING_INCDIR}/libnet/
39         install -m 0644 include/libnet/libnet-asn1.h ${STAGING_INCDIR}/libnet/
40         install -m 0644 include/libnet/libnet-ospf.h ${STAGING_INCDIR}/libnet/
41         oe_libinstall -a -C lib libnet ${STAGING_LIBDIR}
42 }