Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libmimedir / libmimedir_0.3.1.bb
1 DESCRIPTION = "RFC2425 MIME Directory Profile library, supporting vCard and iCalendar"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 DEPENDS = "intltool-native"
6 FILE_PR = "r4"
7
8 # 0.3.1 has at least 2 known bugs which may lead to data corruption/loss:
9 # 1. Arbitrary cutting off of NOTE field during parsing.
10 # 2. Parsing only one value from CATEGORIES field.
11 DEFAULT_PREFERENCE = "-1"
12
13 SRC_URI = "http://www.rittau.org/mimedir/${P}.tar.gz \
14            file://mimedir-duration.diff;patch=1"
15
16 inherit autotools pkgconfig
17
18 EXTRA_OECONF = "--disable-gtk-doc"
19
20 do_stage() {
21 autotools_stage_all
22 }
23
24
25 PACKAGES += "libmimedir-utils"
26 FILES_libmimedir-utils = "${bindir}"
27 FILES_${PN} = "${libdir}/*.so.*"