Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libid3tag / libid3tag_0.15.1b.bb
1 SECTION = "libs"
2 PRIORITY = "optional"
3 DEPENDS = "zlib"
4 DESCRIPTION = "Library for interacting with ID3 tags."
5 LICENSE = "GPL"
6 FILE_PR = "r1"
7
8 SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libid3tag-${PV}.tar.gz \
9            file://id3tag.pc"
10
11 S = "${WORKDIR}/libid3tag-${PV}"
12
13 inherit autotools pkgconfig
14
15 EXTRA_OECONF = "-enable-speed"
16
17 do_configure_prepend() {
18     install -m 0644 ${WORKDIR}/id3tag.pc ${S}
19 }
20 do_stage() {
21         oe_libinstall -so libid3tag ${STAGING_LIBDIR}
22         install -m 0644 id3tag.h ${STAGING_INCDIR}
23 }