merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / libgpg-error / libgpg-error_0.7.bb
1 PR = "r4"
2 DESCRIPTION = "GPG-Error library"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL LGPL FDL"
6
7 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-${PV}.tar.gz \
8            file://pkgconfig.patch;patch=1"
9
10 # move libgpg-error-config into -dev package
11 FILES_${PN} = "${libdir}/lib*.so.*"
12 FILES_${PN}-dev += "${bindir}"
13
14 inherit autotools binconfig pkgconfig
15
16 do_stage() {
17         oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
18         install -d ${STAGING_BINDIR_CROSS}/
19         install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
20
21         install -d ${STAGING_INCDIR}/
22         for X in gpg-error.h
23         do
24                 install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
25         done
26
27         install -d ${STAGING_DATADIR}/aclocal
28         install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
29 }