Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libao / libao-alsa_0.8.6.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "A cross platform audio library. This is the ALSA plugin."
3 HOMEPAGE = "http://www.xiph.org/ao/"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 DEPENDS = "alsa-lib libao"
7 PR = "r2"
8
9 SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
10 S = "${WORKDIR}/libao-${PV}"
11
12 inherit autotools pkgconfig
13
14 EXTRA_OECONF = "--disable-esd --disable-esdtest \
15                 --disable-oss \
16                 --enable-alsa09 --enable-alsa09-mmap \
17                 --disable-arts --disable-nas"
18
19 do_stage() {
20         oe_libinstall -so -C src libao ${STAGING_LIBDIR}
21 }
22
23 PACKAGES = "${PN}-dbg libao-alsa-plugin libao-alsa-plugin-dev"
24 FILES_libao-alsa-plugin= "${libdir}/ao/plugins-2/libalsa*.so"
25 FILES_libao-alsa-plugin-dev += "${libdir}/ao/plugins-2/libalsa*.la"