iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / lcd4linux / lcd4linux_0.10.0.bb
1 DESCRIPTION = "LCD4Linux is a small program that grabs information from the kernel and some subsystems and displays it on an external liquid crystal display."
2 LICENSE = "GPLv2"
3
4 DEPENDS = "libusb ncurses readline virtual/libx11"
5
6 PV = "0.10.0+0.10.1-RC2"
7 PR = "r1"
8
9 SRC_URI = "http://ssl.bulix.org/projects/lcd4linux/raw-attachment/wiki/Download/lcd4linux-0.10.1-RC2.tar.gz \
10            file://lcd4linux.init"
11
12 S =  "${WORKDIR}/lcd4linux-0.10.1-RC2"
13
14
15 inherit autotools update-rc.d
16
17 INITSCRIPT_NAME = "lcd4linux"
18 CONFFILES_${PN} += "${sysconfdir}/lcd4linux.conf"
19
20 do_install_append() {
21         install -d ${D}/${sysconfdir}
22         install -m 0600 ${S}/lcd4linux.conf.sample  ${D}/${sysconfdir}/lcd4linux.conf
23         install -d ${D}/${INIT_D_DIR}
24         install -m 0755 ${WORKDIR}/lcd4linux.init ${D}/${INIT_D_DIR}/lcd4linux
25 }
26