vortex86sx: we use sisfb which gives 2D acceleration
[vuplus_openembedded] / packages / konqueror / konqueror-embedded_20070316.bb
1 DESCRIPTION = "KDE Web Browser Konqueror, QtE based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.konqueror.org/"
5 DEPENDS = "openssl libpcre virtual/libqte2 dcopidl-native dcopidl2cpp-native"
6 LICENSE = "LGPL GPL"
7 PR = "r6"
8
9 # this Konqueror needs the KDEDIR set and the font helvetica installed on the target
10
11 inherit autotools
12
13 SRC_URI = "http://www.basyskom.de/uploads/175/37/kdenox_snapshot_qt2_20070316.tar.bz2 \
14            file://dont-use-kde-config.patch;patch=1 \
15            file://konqe_new_opie.patch;patch=1 \
16            file://konqe-kapplication.patch;patch=1 \
17            file://fix_configure.patch;patch=1"
18 S = "${WORKDIR}/kdenox"
19
20 export QMAKE = "${STAGING_BINDIR_NATIVE}/qmake"
21 export MOC = "${STAGING_BINDIR_NATIVE}/moc"
22 export UIC = "${STAGING_BINDIR_NATIVE}/uic"
23 #export exec_prefix = "${palmtopdir}"
24 #export CXXFLAGS = "-fexceptions -frtti -DKJS_VERBOSE=1 -DQT_THREAD_SUPPORT -DQ_OS_UNIX -DQT_NO_DOM -DENABLE_BOOKMARKS"
25 export CXXFLAGS = "-fexceptions -frtti -DKJS_VERBOSE=1 -DQT_THREAD_SUPPORT -DQ_OS_UNIX -DENABLE_BOOKMARKS"
26 export PCRE_CONFIG = "invalid"
27 # uncomment this for a static build
28 # EXTRAFLAGS = "-lts"
29 # EXTRAFLAGS_c7x0 = "-lts -laticore"
30 export EXTRA_OEMAKE = "EXTRA_LDFLAGS='${EXTRAFLAGS}'"
31
32 EXTRA_OECONF = '--prefix=${palmtopdir} \
33         --exec-prefix=${palmtopdir} \
34 #       --includedir=${STAGING_INCDIR} \
35         --includedir=/usr/include \
36         --with-extra-includes=${STAGING_INCDIR} \
37         --with-extra-libs=${STAGING_LIBDIR} \
38         --with-qtopia-dir=${OPIEDIR} \
39         --with-ssl-version=0.9.7e \
40         --with-ssl-dir=${STAGING_DIR_HOST}${layout_exec_prefix} \
41         --with-qt-includes=${STAGING_DIR_HOST}/qt2/include \
42         --with-qt-libraries=${STAGING_DIR_HOST}/qt2/lib \
43         --with-qt-dir=${QTDIR} \
44         --enable-fontsubs \
45         --with-konq-tmp-prefix=/tmp/kde-cache \
46 #       --enable-static \
47         --disable-static \
48         --enable-shared \
49         --disable-debug \
50         --with-gui=road \
51         --with-ipv6-lookup=no \
52         --without-xinerama \
53 #       --disable-scrollbars \
54         --disable-selection \
55         --disable-bookmarks \
56         --with-javascript=static \
57         --enable-debug=yes \
58         --disable-printing \
59 #       --enable-pcre \
60         --disable-pcre \
61         --without-arts \
62         --enable-jshostext \
63         --disable-selection \
64         --enable-final \
65         --enable-qt-embedded \
66         --enable-rtti-embedded \
67         --enable-mt \
68         --enable-qpe \
69         --enable-qt-mt \
70         --enable-fwnewepg=yes \
71         --enable-embedded '
72
73 do_configure_prepend() {
74         cd ${S}
75         if ! test -L admin
76         then
77             ln -s ../kdelibs/admin admin
78         fi
79 }
80
81 do_compile_prepend() {
82         perl admin/am_edit
83 }
84
85 do_install_append() {
86         install -d ${D}${palmtopdir}/apps/Applications
87         install -m 0644 ${FILESDIR}/konqueror.desktop ${D}${palmtopdir}/apps/Applications/
88         install -d ${D}${palmtopdir}/pics/konqueror
89         install -m 0644 ${FILESDIR}/konqueror.png ${D}${palmtopdir}/pics/konqueror/
90         mv ${D}${palmtopdir}/bin ${D}${bindir}
91         mv ${D}${bindir}/konqueror ${D}${bindir}/konqueror.bin
92         { echo '#!/bin/sh' ; echo "KDEDIR=/usr exec ${bindir}/konqueror.bin" ; } > ${D}${bindir}/konqueror
93         chmod 0755 ${D}${bindir}/konqueror
94 }
95
96 FILES_${PN} = "${palmtopdir} ${datadir} ${bindir}/konqueror* ${libdir}/libkonq*"