Introduce STAGING_BINDIR_CROSS and STAGING_BINDIR_NATIVE as discussed on the mailing...
[vuplus_openembedded] / packages / konqueror / konqueror-embedded_20030705.bb
1 DESCRIPTION = "KDE Web Browser Konqueror, QtE based Palmtop Environments Edition"
2 HOMEPAGE = "http://www.konqueror.org/embedded"
3 SECTION = "opie/applications"
4 PRIORITY = "optional"
5 DEPENDS = "libqpe-opie openssl libpcre"
6 LICENSE = "LGPL/GPL"
7 PR = "r5"
8
9 # Note if this .bb files fails with the error:
10 # "No rule to make target `-lpcre', needed by `konqueror'.  Stop."
11 # a workaround is to install the libpcre3-dev package onto your build 
12 # machine (Ubuntu/Debain) or your distro's equivalent (FC = pcre-devel).
13
14 SRC_URI = "http://devel-home.kde.org/~hausmann/snapshots/Attic/konqueror-embedded-snapshot-${PV}.tar.gz \
15            file://opie1.patch;patch=1 \
16            file://packing.patch;patch=1 \
17            file://include_qconfig.patch;patch=1 \
18            file://useragent.patch;patch=1 \
19            file://kcookiejar-merge.patch;patch=1 \
20            file://malformed.patch;patch=1 \
21            file://cachepath.patch;patch=1 \
22            file://vit.patch;patch=1 \
23            file://gcc4.patch;patch=1 \
24            file://konq-embedrc"
25 S = "${WORKDIR}/konqueror-embedded-snapshot-${PV}"
26
27 inherit autotools
28
29 FILES_${PN} = "${palmtopdir}"
30
31 export QMAKE = "${STAGING_BINDIR_NATIVE}/qmake"
32 export MOC = "${STAGING_BINDIR_NATIVE}/moc"
33 export UIC = "${STAGING_BINDIR_NATIVE}/uic"
34 export exec_prefix = "${STAGING_LIBDIR}/.."
35
36 EXTRA_OECONF = '--prefix=${palmtopdir} --exec-prefix=${palmtopdir}                              \
37                 --enable-static --disable-shared --disable-debug                                \
38                 --with-javascript=static --enable-qpe --enable-qt-embedded                      \
39                 --with-extra-includes=${STAGING_INCDIR} --with-extra-libs=${STAGING_LIBDIR}     \
40                 --with-ssl-version=0.9.7c --with-ssl-dir=${STAGING_LIBDIR}/..                   \
41                 --with-qt-dir=${QTDIR} --with-qtopia-dir=${OPIEDIR}                             \
42                 --enable-libsuffix=""                                                           '
43
44 CXXFLAGS += "-DOPIE_NO_ERASE_RECT_HACKFIX -DOPIE_NEW_MALLOC"
45
46 do_compile_prepend() {
47         perl admin/am_edit
48 }
49
50 do_install() {
51     install -d ${D}${palmtopdir}/share/
52     install -d ${D}${palmtopdir}/share/config/
53     
54     install -m 0644 ${WORKDIR}/konq-embedrc ${D}${palmtopdir}/share/config/
55     
56     autotools_do_install
57 }