checksums.ini: add checksum for pengutronix canutils
[vuplus_openembedded] / packages / kexecboot / kexecboot_0.4.bb
1 LICENSE = "GPL"
2 PR = "r4"
3 DEPENDS = "klibc"
4 RDEPENDS = "kexec-static"
5
6 inherit autotools
7
8 # You can create your own *-img.h by doing
9 # ./make-image-header.sh <file>.png HAND
10
11 SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
12         file://add-reboot-option.patch;patch=1 \
13         file://scan_devices-top.patch;patch=1 \
14         file://graphical-no-devices.patch;patch=1 \
15         file://switch-cursor-off.patch;patch=1 \
16         file://add-sleep.patch;patch=1 \
17         file://silent-output-hack.patch;patch=1 \
18         file://kexecboot-tosa.patch;patch=1 \
19         file://fb-render-16bit.patch;patch=1 \
20         file://logo-img.h \
21         file://logo.png \
22         "
23
24 S = "${WORKDIR}/kexecboot-${PV}"
25
26 export CC=${TARGET_PREFIX}klcc
27
28 # standard oe cflags don't work with klcc
29 export CFLAGS = ""
30 export CPPFLAGS = ""
31 export LDFLAGS = ""
32
33 do_configure_prepend () {
34     install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
35     install -m 0644 ${WORKDIR}/logo.png ${S}/res/
36 }
37
38 do_install () {
39         install -d ${D}${bindir}
40         install -m 0755 kexecboot ${D}${bindir}/
41
42         install -d ${D}/proc
43         install -d ${D}/mnt
44 }
45
46 FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
47
48 pkg_postinst_${PN} () {
49         ln -sf ${bindir}/kexecboot $D/init
50 }