Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / jack / jack_0.103.0.bb
1 DESCRIPTION = "JACK is a low-latency audio server. It can \
2 connect a number of different applications to an audio \
3 device, as well as allowing them to share audio between \
4 themselves."
5 SECTION = "libs/multimedia"
6 PRIORITY = "optional"
7 LICENSE = "GPL LGPL"
8 FILE_PR = "r0"
9
10 DEPENDS = "alsa-lib"
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/jackit/jack-audio-connection-kit-${PV}.tar.gz"
13 S = "${WORKDIR}/jack-audio-connection-kit-${PV}"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF = "--enable-timestamps --disable-capabilities --disable-oldtrans \
18                 --disable-portaudio --disable-coreaudio --enable-oss --enable-alsa"
19
20 EXTRA_OEMAKE = 'transform="s,^,,"'
21 LDFLAGS_append = " -ldl -L${STAGING_LIBDIR}"
22
23 PACKAGES =+ "libjack jack-server jack-examples"
24
25 FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
26 FILES_jack-server = "${bindir}/jackd"
27 FILES_jack-examples = "${bindir}/*"
28
29 do_stage() {
30        autotools_stage_all
31 }
32