merge of '7393275c6ccce67cadeb49d4afb3459e56edf8a9'
[vuplus_openembedded] / packages / ixp4xx / ixp4xx-npe_2.4.bb
1 DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
2 LICENSE = "Intel"
3 PR = "r1"
4 DEPENDS = "ixp4xx-npe-native"
5
6 # You need to download the IPL_ixp400NpeLibrary-2_4.zip file (without crypto) from:
7 # http://www.intel.com/design/network/products/npfamily/download_ixp400.htm
8 # "Intel IXP400 software - NPE microcode (non-crypto)" -> "2.4"
9 # and put it in your downloads directory so bitbake will find it.
10 # Make sure you *read* and accept the license - it is not a standard one.
11
12 SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.4.bb-For-Instructions/IPL_ixp400NpeLibrary-2_4.zip \
13            file://Intel"
14 S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
15
16 COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
17
18 FILES_${PN} = "${base_libdir}/firmware/NPE-B ${base_libdir}/firmware/NPE-C"
19
20 do_compile() {
21         ${STAGING_BINDIR_NATIVE}/IxNpeMicrocode-${PV} -be
22 }
23
24 do_install() {
25         install -d ${D}/${base_libdir}/firmware/
26         rm ${S}/NPE-B
27         mv ${S}/NPE-B.* ${S}/NPE-B
28         install ${S}/NPE-B ${D}/${base_libdir}/firmware/
29         rm ${S}/NPE-C
30         mv ${S}/NPE-C.* ${S}/NPE-C
31         install ${S}/NPE-C ${D}/${base_libdir}/firmware/
32         install -d ${D}/${datadir}/common-licenses/
33         install -m 0644 ${WORKDIR}/Intel ${D}${datadir}/common-licenses/
34 }
35
36 do_stage() {
37         install -d ${STAGING_FIRMWARE_DIR}
38         install ${S}/NPE-B ${STAGING_FIRMWARE_DIR}/
39         install ${S}/NPE-C ${STAGING_FIRMWARE_DIR}/
40 }
41