merge
[vuplus_openembedded] / packages / ixp4xx / ixp4xx-npe_2.3.2.bb
1 DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
2 LICENSE = "Intel Public Licence"
3 PR = "r1"
4 DEPENDS = "ixp4xx-npe-native"
5
6 # You need to download the IPL_ixp400NpeLibrary-2_3_2.zip file (without crypto) from:
7 # http://www.intel.com/design/network/products/npfamily/ixp400_current.htm
8 # and put it in your downloads directory so bitbake will find it.
9 # Make sure you *read* and accept the license - it is not a standard one.
10
11 SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
12 S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
13
14 COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
15
16 FILES_${PN} = "${base_libdir}/firmware/NPE-B ${base_libdir}/firmware/NPE-C"
17
18 do_compile() {
19         ${STAGING_BINDIR_NATIVE}/IxNpeMicrocode-${PV} -be
20 }
21
22 do_install() {
23         install -d ${D}/${base_libdir}/firmware/
24         rm ${S}/NPE-B
25         mv ${S}/NPE-B.* ${S}/NPE-B
26         install ${S}/NPE-B ${D}/${base_libdir}/firmware/
27         rm ${S}/NPE-C
28         mv ${S}/NPE-C.* ${S}/NPE-C
29         install ${S}/NPE-C ${D}/${base_libdir}/firmware/
30 }
31
32 do_populate_staging() {
33         install -d ${STAGING_FIRMWARE_DIR}
34         install ${S}/NPE-B ${STAGING_FIRMWARE_DIR}/
35         install ${S}/NPE-C ${STAGING_FIRMWARE_DIR}/
36 }
37