merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / ipkg-utils / ipkg-utils_1.6+cvs20050404.bb
1 DESCRIPTION = "Itsy Package Manager utilities"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 CONFLICTS = "ipkg-link"
6 RDEPENDS = "python"
7 SRCDATE = "20050404"
8 PR = "r21"
9
10 SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
11            file://ipkg-utils-fix.patch;patch=1 \
12            file://ipkg-py-sane-vercompare.patch;patch=1 \
13            file://ipkg-py-tarfile.patch;patch=1 \
14            file://arfile_even_alignment.patch;patch=1 \
15            file://ipkg-make-index-track-stamps.patch;patch=1 \
16            file://fields_tweaks.patch;patch=1 "
17
18 S = "${WORKDIR}/ipkg-utils"
19
20 INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py ipkg-list-fields"
21
22 do_compile() {
23         oe_runmake ipkg-compare-versions
24 }
25
26 do_install() {
27         install -d ${D}${bindir}
28         for i in ${INSTALL}
29         do
30                 install -m 0755 $i ${D}${bindir}
31         done
32 }
33