Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / iperf / iperf_2.0.2.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
3 HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
4 LICENSE = "BSD"
5 PR = "r0"
6
7 SRC_URI = "http://dast.nlanr.net/Projects/Iperf2.0/iperf-${PV}.tar.gz"
8 #       file://socketaddr-h-errno.diff;patch=1"
9
10 inherit autotools
11
12 S="${WORKDIR}/iperf-${PV}"
13
14 # --disable-threads is needed on epia/x86 with uclibc
15 do_configure() {
16         gnu-configize
17         oe_runconf --exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}  --disable-threads
18 }
19
20 do_compile() {
21         cd ${WORKDIR}/iperf-${PV}
22         oe_runmake
23 }
24
25 do_install() {
26         cd ${WORKDIR}/iperf-${PV}/src
27         oe_runmake DESTDIR=${D} install
28 }