merge of '0521752c751b5734b320120045655229b2faff4f'
[vuplus_openembedded] / packages / images / fso-image.bb
1 #------------------------------------------------------
2 # freesmartphone.org Image Recipe
3 #------------------------------------------------------
4
5 IMAGE_LINGUAS = ""
6
7 # getting the base system up
8 BASE_INSTALL = "\
9   ${MACHINE_TASK_PROVIDER} \
10   netbase \
11   sysfsutils \
12   module-init-tools-depmod \
13   rsync \
14   screen \
15   fbset \
16   fbset-modes \
17 "
18
19 # getting an X window system up
20 X_INSTALL = "\
21   e-wm \
22   illume \
23   illume-theme-freesmartphone \
24   ${XSERVER} \
25   xserver-kdrive-common \
26   xserver-nodm-init \
27   xauth \
28   xhost \
29   xset \
30   xrandr \
31   \
32   fontconfig-utils \
33   \
34   ttf-dejavu-common \
35   ttf-dejavu-sans \
36   ttf-dejavu-serif \
37   \
38 "
39
40 # useful command line tools
41 TOOLS_INSTALL = "\
42 #  bash \
43   dosfstools \
44   htop \
45   iptables \
46   lsof \
47   mickeydbus \
48   mickeyterm \
49   mtd-utils \
50   nano \
51   powertop \
52   s3c24xx-gpio \
53 "
54
55 # audio
56 AUDIO_INSTALL = "\
57   alsa-oss \
58   alsa-state \
59   alsa-utils-aplay \
60   gst-meta-audio \
61   gst-plugin-mad \
62   gst-plugin-modplug \
63   gst-plugin-sid \
64   fso-sounds \
65 "
66
67 GTK_INSTALL = "\
68   openmoko-calculator2 \
69   openmoko-terminal2 \
70   gpe-scap \
71   tangogps-fso \
72 "
73
74 GAMES_INSTALL = "\
75   numptyphysics \
76 "
77
78 # FIXME these should rather be part of alsa-state,
79 # once Om stabilizes them...
80 AUDIO_INSTALL_append_om-gta01 = "\
81   openmoko-alsa-scenarios \
82 "
83 AUDIO_INSTALL_append_om-gta02 = "\
84   openmoko-alsa-scenarios \
85 "
86
87 # python
88 PYTHON_INSTALL = "\
89   task-python-efl \
90   python-codecs \
91   python-gst \
92 "
93
94 # zhone
95 ZHONE_INSTALL = "\
96   gsm0710muxd \
97   frameworkd \
98   zhone \
99 "
100
101 IMAGE_INSTALL = "\
102   ${BASE_INSTALL} \
103   ${X_INSTALL} \
104   ${GTK_INSTALL} \
105   ${GAMES_INSTALL} \
106   ${AUDIO_INSTALL} \
107   ${TOOLS_INSTALL} \
108   ${PYTHON_INSTALL} \
109   ${ZHONE_INSTALL} \
110 "
111
112 inherit image
113
114 # perform some convenience tweaks to the rootfs
115 fso_rootfs_postprocess() {
116     curdir=$PWD
117     cd ${IMAGE_ROOTFS}
118     # date/time
119     date "+%m%d%H%M%Y" >./etc/timestamp
120     # alias foo
121     echo "alias pico=nano" >>./etc/profile
122     echo "alias fso='cd /local/pkg/fso'" >>./etc/profile
123     echo "alias ipkg='opkg'" >>./etc/profile
124     # nfs
125     mkdir -p ./local/pkg
126     echo >>./etc/fstab
127     echo "# NFS Host" >>./etc/fstab
128     echo "192.168.0.200:/local/pkg /local/pkg nfs noauto,nolock,soft,rsize=32768,wsize=32768 0 0" >>./etc/fstab
129     # fix .desktop files for illume
130     desktop=`find ./usr/share/applications -name "*.desktop"`
131     for file in $desktop; do
132         echo "Categories=Office;" >>$file
133     done
134     # minimal gtk theme foo
135     mkdir -p ./etc/gtk-2.0/
136     echo 'gtk-font-name = "Sans 5"' >> ./etc/gtk-2.0/gtkrc
137     cd $curdir
138 }
139
140 ROOTFS_POSTPROCESS_COMMAND += "fso_rootfs_postprocess"