classpath-native: Fix typo in depends.
[vuplus_openembedded] / packages / images / fso-image.bb
1 #------------------------------------------------------
2 # freesmartphone.org Image Recipe
3 #------------------------------------------------------
4
5 IMAGE_LINGUAS = ""
6
7 # getting the base system up
8 BASE_INSTALL = "\
9   ${MACHINE_TASK_PROVIDER} \
10   netbase \
11   sysfsutils \
12   module-init-tools-depmod \
13   rsync \
14   screen \
15   fbset \
16   fbset-modes \
17 "
18
19 # getting an X window system up
20 X_INSTALL = "\
21   e-wm \
22   illume \
23   illume-theme-freesmartphone \
24   ${XSERVER} \
25   xserver-kdrive-common \
26   xserver-nodm-init \
27   xauth \
28   xhost \
29   xset \
30   xrandr \
31   \
32   fontconfig-utils \
33   \
34   ttf-dejavu-common \
35   ttf-dejavu-sans \
36   ttf-dejavu-serif \
37   \
38 "
39
40 # useful command line tools
41 TOOLS_INSTALL = "\
42 #  bash \
43   dosfstools \
44   htop \
45   iptables \
46   lsof \
47   mickeydbus \
48   mickeyterm \
49   mtd-utils \
50   nano \
51   powertop \
52   s3c24xx-gpio \
53 "
54
55 # audio
56 AUDIO_INSTALL = "\
57   alsa-oss \
58   alsa-state \
59   alsa-utils-aplay \
60   gst-meta-audio \
61   gst-plugin-mad \
62   gst-plugin-modplug \
63   gst-plugin-sid \
64   fso-sounds \
65 "
66
67 # FIXME these should rather be part of alsa-state,
68 # once Om stabilizes them...
69 AUDIO_INSTALL_append_om-gta01 = "\
70   openmoko-alsa-scenarios \
71 "
72 AUDIO_INSTALL_append_om-gta02 = "\
73   openmoko-alsa-scenarios \
74 "
75
76 # python
77 PYTHON_INSTALL = "\
78   task-python-efl \
79   python-codecs \
80   python-gst \
81 "
82
83 # zhone
84 ZHONE_INSTALL = "\
85   gsm0710muxd \
86   frameworkd \
87   zhone \
88 "
89
90 IMAGE_INSTALL = "\
91   ${BASE_INSTALL} \
92   ${X_INSTALL} \
93   ${AUDIO_INSTALL} \
94   ${TOOLS_INSTALL} \
95   ${PYTHON_INSTALL} \
96   ${ZHONE_INSTALL} \
97 "
98
99 inherit image
100
101 # perform some convenience tweaks to the rootfs
102 fso_rootfs_postprocess() {
103     curdir=$PWD
104     cd ${IMAGE_ROOTFS}
105     date "+%m%d%H%M%Y" >./etc/timestamp
106     echo "alias pico=nano" >>./etc/profile
107     echo "alias fso='cd /local/pkg/fso'" >>./etc/profile
108     echo "alias ipkg='opkg'" >>./etc/profile
109     mkdir -p ./local/pkg
110     echo >>./etc/fstab
111     echo "# NFS Host" >>./etc/fstab
112     echo "192.168.0.200:/local/pkg /local/pkg nfs noauto,nolock,soft,rsize=32768,wsize=32768 0 0" >>./etc/fstab
113     cd $curdir
114 }
115
116 ROOTFS_POSTPROCESS_COMMAND += "fso_rootfs_postprocess"