Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / images / fso-image-nox.bb
1 #------------------------------------------------------
2 # freesmartphone.org Image Recipe, No-x11 Edition
3 #------------------------------------------------------
4
5 PR = "r1.0"
6
7 require fso-image.bb
8
9 export IMAGE_BASENAME = "fso-image-nox"
10
11 # The packages below should ideally be a subset of the
12 # full fso-image.  But unfortunately, the granularity
13 # and some of the assumptions of the fso image do not
14 # yet permit that.  The gating factor is that this
15 # particular image needs to include the necessary stuff
16 # so that Qt Extended can run, but not so much that
17 # it can no longer fit in the small flash available on
18 # the GTA01.  So, in practice this means that we will
19 # need some X libs (for dbus at a minimum), but we need
20 # to ensure that we limit that as much as possible.
21 #
22 # (There is little doubt that as the software stacks
23 # mature, the GTA01 will need to become SD-card based.
24 # Never-the-less, it is desirable to keep this as small
25 # as possible for as long as possible.)
26 #
27 # Note: if packages are _added_ to this image, it is
28 # important to also add the -dev versions of that
29 # package to the toolchain, if applicable.  In general,
30 # _adding_ packages to this file is a bad idea; this
31 # image should be a proper subset of the full fso image.
32 #
33
34 AUDIO_NOX_INSTALL = "\
35   alsa-oss \
36   alsa-state \
37   alsa-utils-aplay \
38   alsa-utils-amixer \
39   openmoko-alsa-scenarios \
40 "
41
42 # python - just pull in some basics for now.  Ideally we would like
43 # to be able to run parts of the framework, but that's a future, and
44 # would almost certainly require an SD card on the GTA01.  So just
45 # add the basics so that we at least have a scripting language.
46 ##
47 # (I'm really of two minds on this; removing python is a big
48 # win in terms of flash space, and I'm not sure how useful this
49 # small set is.  Need comments from others.  --- MJW)
50
51 PYTHON_NOX_INSTALL = "\
52   python-dbus \
53   python-pygobject \
54 "
55
56 # Tools - carefully picked so that we don't pull in too much.
57 # This list should be edited -- in particular, s3c24xx-gpio is large
58 # and statically linked.  If not needed, we can save some flash on the
59 # GTA01 by getting rid of it in the base image.  Other candidates
60 # might include nano, mickeydbus, powertop, sysstat, and tcpdump.
61
62 TOOLS_NOX_INSTALL = "\
63   dosfstools \
64   htop \
65   iptables \
66   lsof \
67   mickeydbus \
68   mtd-utils \
69   nano \
70   powertop \
71   s3c24xx-gpio \
72   sysstat \
73   tcpdump \
74 "
75
76 # This block is intended to pull in stuff that is normally pulled
77 # in as dependencies in the full fso image.  At this moment,
78 # libpng12 is an exception - it slipped into the toolchain, hence
79 # it needs to be here as well.  It should be added to the full
80 # fso image at some point.
81
82 EXTRA_NOX_INSTALL = "\
83   libstdc++ \
84   tslib \
85   pointercal \
86   tzdata \
87   libpng12 \
88 "
89
90 IMAGE_INSTALL = "\
91   ${BASE_INSTALL} \
92   ${EXTRA_NOX_INSTALL} \
93   ${AUDIO_NOX_INSTALL} \
94   ${PYTHON_NOX_INSTALL} \
95   ${TOOLS_NOX_INSTALL} \
96 "
97
98 # The post-processing step for this image is where we can do some
99 # cleanup to get some space back if necessary, or do other touch-up
100 # work specific to this image.  It is currently empty, and should
101 # continue to be empty -- but it appears here because that's probably
102 # unrealistic, so we might as put the placeholder here right now.
103
104 fso_nox_rootfs_postprocess() {
105   curdir=$PWD
106   cd ${IMAGE_ROOTFS}
107   # Execute commands to tweak the rootfs here
108
109   # End commands
110   cd ${curdir}
111 }
112
113 ROOTFS_POSTPROCESS_COMMAND += "fso_nox_rootfs_postprocess"