qi: try harder to fix compiler flags
[vuplus_openembedded] / packages / images / epydial-image.bb
1 # pyneo image recipe
2
3 IMAGE_LINGUAS = "\
4 "
5
6 # base system
7 BASE_INSTALL = "\
8         ${MACHINE_TASK_PROVIDER}\
9         netbase\
10         sysfsutils\
11         module-init-tools-depmod\
12         rsync\
13         screen\
14         fbset\
15         fbset-modes\
16 "
17
18 # getting an X window system up
19 X_INSTALL = "\
20         ${XSERVER}\
21         matchbox-wm\
22         xserver-kdrive-common\
23         xserver-nodm-init\
24         xauth\
25         xhost\
26         xset\
27         xrandr\
28         fontconfig-utils\
29         ttf-dejavu-common\
30         ttf-dejavu-sans\
31         ttf-dejavu-serif\
32 "
33
34 # useful command line tools
35 TOOLS_INSTALL = "\
36         dosfstools\
37         iptables\
38         lsof\
39         mtd-utils\
40         s3c24xx-gpio\
41         sysstat\
42 "
43
44 # media audio/video
45 MEDIA_INSTALL = "\
46         alsa-oss\
47         alsa-state\
48         alsa-utils-aplay\
49         alsa-utils-amixer\
50         gst-meta-audio\
51         gst-plugin-mad\
52         gst-plugin-modplug\
53         gst-plugin-sid\
54         openmoko-alsa-scenarios\
55         mplayer\
56 "
57
58 # summary
59 IMAGE_INSTALL = "\
60         ${BASE_INSTALL}\
61         ${X_INSTALL}\
62         ${MEDIA_INSTALL}\
63         ${TOOLS_INSTALL}\
64         euphony\
65         epydial\
66 "
67
68 inherit image
69
70 # perform some patches to the rootfs
71 rootfs_postprocess() {
72         # image timastamp
73         date "+%m%d%H%M%Y" > ${IMAGE_ROOTFS}/etc/timestamp
74 }
75
76 ROOTFS_POSTPROCESS_COMMAND += "rootfs_postprocess"