dreambox-image: add enigma blindscan plugin to image
[vuplus_openembedded] / packages / images / dreambox-image.bb
1 export IMAGE_BASENAME = "dreambox-image"
2
3 OPENDREAMBOX_COMMON = "base-files busybox \
4         ipkg initscripts-opendreambox sysvinit netbase dropbear \
5         base-passwd ncurses joe mc vsftpd timezones-alternative \
6         netkit-base fakelocale less dreambox-bootlogo  \
7         dreambox-dccamd dreambox-keymaps tuxbox-image-info dvbsnoop \
8         dreambox-compat tuxbox-common mrouted smartmontools hddtemp"
9
10 OPENDREAMBOX_COMMON_D = "util-linux e2fsprogs \
11         ppp module-init-tools samba"
12
13 OPENDREAMBOX_COMMON_R = "util-linux-sfdisk util-linux-fdisk e2fsprogs-mke2fs \
14         e2fsprogs-e2fsck ppp module-init-tools-depmod \
15         base-files-doc sambaserver"
16
17 # experimental packages
18 OPENDREAMBOX_EXPERIMENTAL = "enigma2 tuxbox-tuxtxt-32bpp twisted twisted-web2"
19 OPENDREAMBOX_EXPERIMENTAL_R = "enigma2-plugin-systemplugins-frontprocessorupgrade \
20         enigma2-plugin-systemplugins-softwareupdate \
21         enigma2-plugin-systemplugins-positionersetup \
22         enigma2-plugin-extensions-cutlisteditor \
23         enigma2-plugin-systemplugins-configurationbackup \
24         enigma2-plugin-systemplugins-satfinder \
25         enigma2-plugin-extensions-webinterface \
26         enigma2-plugin-systemplugins-skinselector \
27         enigma2-plugin-extensions-pictureplayer \
28         enigma2-skins \ 
29         enigma2-streamproxy \
30         twisted-web2 twisted python-crypt python-crypto \
31         python-netserver python-pickle dreambox-blindscan-utils"
32
33 # legacy tuxbox stuff (enigma, plugins, ...)
34 OPENDREAMBOX_TUXBOX = "enigma ipkgpl"
35 OPENDREAMBOX_TUXBOX_D = "tuxbox-plugins tuxbox-plugins-enigma links-dream"
36 OPENDREAMBOX_TUXBOX_R = " \
37         tuxbox-plugin-snake     tuxbox-plugin-tuxmail \
38         tuxbox-plugin-lcdcirc   tuxbox-plugin-soko      tuxbox-plugin-tuxtxt \
39         tuxbox-plugin-sol       tuxbox-plugin-vierg     tuxbox-plugin-master \
40         tuxbox-plugin-solitair  tuxbox-plugin-yahtzee   tuxbox-plugin-mines  \
41         tuxbox-plugin-tank      tuxbox-plugin-pacman    tuxbox-plugin-tetris \
42         tuxbox-plugin-satfind   tuxbox-plugin-tuxcom    links-dream-plugin \
43         links-dream-plugin enigma-plugin-dreamdata"
44
45 OPENDREAMBOX_TUXBOX_R_dm600pvr = " \
46         tuxbox-plugin-snake     tuxbox-plugin-tuxmail \
47         tuxbox-plugin-soko      tuxbox-plugin-tuxtxt \
48         tuxbox-plugin-sol       tuxbox-plugin-vierg     tuxbox-plugin-master \
49         tuxbox-plugin-solitair  tuxbox-plugin-yahtzee   tuxbox-plugin-mines  \
50         tuxbox-plugin-tank      tuxbox-plugin-pacman    tuxbox-plugin-tetris \
51         tuxbox-plugin-tuxcom    links-dream-plugin      enigma-blindscan"
52
53 OPENDREAMBOX_TUXBOX_R_dm500plus = " \
54         tuxbox-plugin-snake     tuxbox-plugin-tuxmail \
55         tuxbox-plugin-soko      tuxbox-plugin-tuxtxt \
56         tuxbox-plugin-sol       tuxbox-plugin-vierg     tuxbox-plugin-master \
57         tuxbox-plugin-solitair  tuxbox-plugin-yahtzee   tuxbox-plugin-mines  \
58         tuxbox-plugin-tank      tuxbox-plugin-pacman    tuxbox-plugin-tetris \
59         tuxbox-plugin-tuxcom    links-dream-plugin      enigma-blindscan"
60
61 # dvb api specific stuff
62 OPENDREAMBOX_V2_ONLY = "dreambox-dvb-tools tuxbox-stream"
63 OPENDREAMBOX_V3_ONLY = "dreambox-dvb-tools-v3 sctzap dvbtraffic"
64
65 # enigma languages
66 # disabled: enigma-locale-ar enigma-locale-sr enigma-locale-ur
67 ENIGMA_LANGUAGE = "enigma-locale-cs enigma-locale-da \
68         enigma-locale-de enigma-locale-el enigma-locale-es enigma-locale-et \
69         enigma-locale-fi enigma-locale-fr enigma-locale-hr enigma-locale-hu \
70         enigma-locale-is enigma-locale-it enigma-locale-lt enigma-locale-nl \
71         enigma-locale-no enigma-locale-pl enigma-locale-pt enigma-locale-ro \
72         enigma-locale-ru enigma-locale-sk enigma-locale-sl \
73         enigma-locale-sv enigma-locale-tr"
74
75 OPENDREAMBOX_TUXBOX_R += " ${ENIGMA_LANGUAGE}"
76 OPENDREAMBOX_TUXBOX_R_dm600pvr += " ${ENIGMA_LANGUAGE}"
77 OPENDREAMBOX_TUXBOX_R_dm500plus += " ${ENIGMA_LANGUAGE}"
78
79 MODEM_SUPPORT = "enigma-modem"
80 MODEM_SUPPORT_R = "kernel-module-crc-ccitt kernel-module-ppp-async \
81         kernel-module-ppp-generic \
82         kernel-module-slhc update-modules"
83
84 # now machine specific:
85 OPENDREAMBOX_COMMON_MACHINE_dm600pvr += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_TUXBOX} ${MODEM_SUPPORT}"
86 OPENDREAMBOX_COMMON_MACHINE_R_dm600pvr += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R} dreambox-blindscan-utils"
87 OPENDREAMBOX_COMMON_MACHINE_D_dm600pvr += "${OPENDREAMBOX_TUXBOX_D}"
88
89 OPENDREAMBOX_COMMON_MACHINE_dm500plus += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_TUXBOX} ${MODEM_SUPPORT}"
90 OPENDREAMBOX_COMMON_MACHINE_R_dm500plus += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R} dreambox-blindscan-utils"
91 OPENDREAMBOX_COMMON_MACHINE_D_dm500plus += "${OPENDREAMBOX_TUXBOX_D}"
92
93 OPENDREAMBOX_COMMON_MACHINE_dm7020 += "${OPENDREAMBOX_V2_ONLY} ${OPENDREAMBOX_TUXBOX} ${MODEM_SUPPORT}"
94 OPENDREAMBOX_COMMON_MACHINE_R_dm7020 += "${OPENDREAMBOX_TUXBOX_R} ${MODEM_SUPPORT_R}"
95 OPENDREAMBOX_COMMON_MACHINE_D_dm7020 += "${OPENDREAMBOX_TUXBOX_D}"
96
97 OPENDREAMBOX_COMMON_MACHINE_dm7025 += "${OPENDREAMBOX_V3_ONLY} ${OPENDREAMBOX_EXPERIMENTAL}"
98 OPENDREAMBOX_COMMON_MACHINE_R_dm7025 += "${OPENDREAMBOX_EXPERIMENTAL_R}"
99 OPENDREAMBOX_COMMON_MACHINE_D_dm7025 += ""
100
101 # collect the stuff into OPENDREAMBOX_COMMON
102 OPENDREAMBOX_COMMON += " ${OPENDREAMBOX_COMMON_MACHINE}"
103 OPENDREAMBOX_COMMON_R += " ${OPENDREAMBOX_COMMON_MACHINE_R}"
104 OPENDREAMBOX_COMMON_D += " ${OPENDREAMBOX_COMMON_MACHINE_D}"
105
106 # add bootstrap stuff
107 DEPENDS = "${OPENDREAMBOX_COMMON} ${BOOTSTRAP_EXTRA_DEPENDS} ${OPENDREAMBOX_COMMON_D}"
108 RDEPENDS = "${OPENDREAMBOX_COMMON} ${BOOTSTRAP_EXTRA_RDEPENDS} ${OPENDREAMBOX_COMMON_R}"
109
110 # we don't want any locales, at least not in the common way.
111 IMAGE_LINGUAS = " "
112
113 export IPKG_INSTALL = '${RDEPENDS}'
114
115 inherit image_ipk