Bluez: removed outdated stuff so multithreaded bitbake doesn't break apps depending...
[vuplus_openembedded] / packages / hotplug-ng / hotplug-ng_001.bb
1 DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
2 package with very tiny, compiled executable programs, instead of the \
3 existing bash scripts."
4 LICENSE = "GPL"
5 RPROVIDES = "hotplug"
6 RCONFLICTS = "hotplug"
7 RREPLACES = "hotplug"
8 PR = "r1"
9
10 SRC_URI = "http://www.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz \
11            file://flags.patch;patch=1"
12 S = "${WORKDIR}/hotplug-ng-${PV}"
13
14 LD = "${CC}"
15 export HOSTCC = "${BUILD_CC}"
16 # Stripping should be done when _packaging_, not building
17 EXTRA_OEMAKE += "'STRIP=/bin/true'"
18
19 export etcdir = "${sysconfdir}"
20 export sbindir = "${base_sbindir}"
21 export bindir = "${base_bindir}"
22
23 do_install () {
24         oe_runmake 'DESTDIR=${D}' install
25 }