Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / horizon / horizon_cvs.bb
1 DESCRIPTION = "Horizon is a sketchbook application for tablet devices."
2 LICENSE = "GPLv2"
3 SECTION = "x11/graphics"
4 DEPENDS = "glib-2.0 libpng jpeg virtual/libsdl"
5 PR = "r1"
6
7 SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=horizon \
8         file://makefile.patch;patch=1"
9
10 inherit pkgconfig binconfig
11
12 S = "${WORKDIR}/horizon"
13 PV = "0.37+cvs${SRCDATE}"
14
15 PARALLEL_MAKE = ""
16
17 CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/SDL -I. -Isrc -L${STAGING_LIBDIR} `PKG_CONFIG_PATH=${STAGING_DATADIR}/pkgconfig pkg-config --cflags glib-2.0 gobject-2.0 libpng`"
18
19 do_compile() {
20         #yes, this is a hack to work around a faulty makefile
21         oe_runmake horizon
22 }
23
24 do_install() {
25         install -d ${D}${bindir}
26         install -m 755 horizon ${D}${bindir}
27 }
28