iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / hal / hal_0.5.9.1.bb
1 DESCRIPTION = "Hardware Abstraction Layer"
2 HOMEPAGE = "http://freedesktop.org/Software/hal"
3 SECTION = "unknown"
4 LICENSE = "GPL LGPL AFL"
5
6 DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
7 RDEPENDS_${PN} += "udev hal-info"
8 RRECOMMENDS_${PN} += "udev-utils"
9
10 PR = "r7"
11
12 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
13            file://configure_fix.patch;patch=1 \
14            file://sg-inhibit.patch;patch=1 \
15            file://20hal \
16            file://99_hal"
17
18 S = "${WORKDIR}/hal-${PV}"
19
20 inherit autotools pkgconfig
21
22 EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
23                 --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
24                 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
25                 --with-hotplug=${sysconfdir}/hotplug.d \
26                 --disable-docbook-docs \
27                 --disable-policy-kit \
28                 --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
29                 --disable-sonypic \
30                 --disable-pmu --disable-pci \
31                 --disable-pci-ids --disable-pnp-ids \
32                 "
33
34 do_install_append() {
35         install -d ${D}/etc/default/volatiles
36         install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
37         install -d ${D}/etc/dbus-1/event.d
38         install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
39 }
40
41 do_stage() {
42         autotools_stage_all
43         install -d ${STAGING_LIBDIR}
44         install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
45         install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
46 }
47
48 # At the time the postinst runs, dbus might not be setup so only restart if running
49 pkg_postinst_hal () {
50         # can not do this offline
51         if [ "x$D" != "x" ]; then
52                 exit 1
53         fi
54
55         /etc/init.d/populate-volatile.sh update
56
57         grep haldaemon /etc/group || addgroup haldaemon
58         grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
59
60         DBUSPID=`pidof dbus-daemon`
61
62         if [ "x$DBUSPID" != "x" ]; then
63                 /etc/init.d/dbus-1 reload
64         fi
65 }
66
67 pkg_postrm_hal () {
68         deluser haldaemon || true
69         delgroup haldaemon || true
70 }
71
72 PACKAGES =+ "libhal libhal-storage"
73
74 FILES_libhal = "${libdir}/libhal.so.*"
75 FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
76
77 FILES_${PN} = "${sysconfdir} \
78                 ${bindir}/lshal \
79                 ${bindir}/hal-find-by-capability \
80                 ${bindir}/hal-find-by-property \
81                 ${bindir}/hal-device  \
82                 ${bindir}/hal-get-property \
83                 ${bindir}/hal-set-property  \
84                 ${bindir}/hal-lock  \
85                 ${bindir}/hal-is-caller-locked-out  \
86                 ${bindir}/hal-disable-polling  \
87                 ${sbindir} \
88                 ${libdir}/libhal.so.* \
89                 ${libdir}/libhal-storage.so.* \
90                 ${libdir}/hal \
91                 ${libexecdir} \
92                 ${datadir}/hal/fdi \
93                 ${datadir}/hal/scripts"