Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / gtk+ / gdk-pixbuf_2.10.14.bb
1 DESCRIPTION = "Stand-alone libpixbuf, a pixelmap image i/o library from the \
2 GTK+ multi-platform toolkit for creating graphical user interfaces."
3 HOMEPAGE = "http://www.gtk.org/"
4 SECTION = "libs"
5 LICENSE = "LGPL"
6 PRIORITY = "optional"
7 DEPENDS = "libpng gettext glib-2.0"
8 PR = "r1"
9
10 S = "${WORKDIR}/gtk+-${PV}"
11 FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
12
13 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
14            file://automake-lossage.patch;patch=1 \
15            file://reduce-dependencies.patch;patch=1"
16
17 #           file://no-xwc.patch;patch=1 \
18 #           file://disable-tooltips.patch;patch=1 \
19 #           file://gtklabel-resize-patch;patch=1 \
20 #           file://menu-deactivate.patch;patch=1 \
21 #           file://xsettings.patch;patch=1 \
22 #           file://scroll-timings.patch;patch=1 \
23 #           file://small-gtkfilesel.patch;patch=1 \
24 #           file://migration.patch;patch=1;pnum=0 \
25 #           file://run-iconcache.patch;patch=1 \
26 #           file://hardcoded_libtool.patch;patch=1 \
27 #           file://no-demos.patch;patch=1 \
28 #           file://single-click.patch;patch=1 \
29 #           file://spinbutton.patch;patch=1 \
30 #           file://gtk+-handhelds.patch;patch=1 \
31 #           file://filesel-fix-segfault.patch;patch=1 \
32 #           file://combo-arrow-size.patch;patch=1;pnum=0 \
33 #           file://range-no-redraw.patch;patch=1;pnum=0 \
34 #           file://scrolled-placement.patch;patch=1;pnum=0 \
35 #           file://treeview-checkbox-size.patch;patch=1;pnum=0 \
36 #           file://cell-renderer-edit-focus.patch;patch=1;pnum=0 \
37
38 inherit autotools pkgconfig
39
40 LIBV = "2.10.0"
41
42 FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
43         ${bindir}/gtk-update-icon-cache \
44         ${libdir}/lib*.so.*"
45
46 FILES_${PN}-dev += " \
47         ${datadir}/gtk-2.0/include \
48         ${libdir}/gtk-2.0/include \
49         ${libdir}/gtk-2.0/${LIBV}/loaders/*.la \
50         ${bindir}/gdk-pixbuf-csource \
51         ${bindir}/gtk-builder-convert"
52
53 FILES_${PN}-dbg += " \
54         ${libdir}/gtk-2.0/${LIBV}/loaders/.debug/*"
55
56 EXTRA_OECONF = "\
57   --without-x \
58   --with-gdktarget=linux-fb \
59   --without-libtiff \
60   --without-libjpeg \
61   --with-libpng \
62 "
63
64 EXTRA_OECONF += "--disable-modules --with-included-loaders=png,tga"
65
66 # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
67 require gtk-fpu.inc
68 EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
69
70 do_compile() {
71         cd gdk-pixbuf && oe_runmake
72 }
73
74 do_stage() {
75         oe_libinstall -C gdk-pixbuf -so libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
76         cd gdk-pixbuf && oe_runmake install DESTDIR=${STAGING_DIR_HOST}${layout_exec_prefix}
77         autotools_stage_includes
78 #       install -d -m 0755 ${STAGING_LIBDIR}/gtk-2.0/include
79 #       install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
80 }
81
82 do_install() {
83         oe_libinstall -C gdk-pixbuf -so libgdk_pixbuf-2.0 ${D}/${libdir}
84         cd gdk-pixbuf && oe_runmake install DESTDIR=${D}
85 }
86