checksums.ini: add checksum for pengutronix canutils
[vuplus_openembedded] / packages / gtk+ / gdk-pixbuf-csource-native_2.12.11.bb
1 require gtk+_${PV}.bb
2 inherit native
3 DEPENDS = "jpeg-native libpng-native gettext-native glib-2.0-native libx11-native"
4 S = "${WORKDIR}/gtk+-${PV}"
5 FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
6 SRC_URI += "file://reduce-dependencies.patch;patch=1"
7
8 #clear recommends for uclibc builds
9 RRECOMMENDS = " "
10 RRECOMMENDS_${PN}_linux = "  "
11 RRECOMMENDS_${PN}_linux-gnueabi = " "
12
13 EXTRA_OECONF = "\
14   --with-gdktarget=x11 \
15   --without-libtiff \
16   --with-libjpeg \
17   --with-libpng \
18 "
19
20 do_compile() {
21         cd gdk-pixbuf && oe_runmake
22 }
23
24 do_stage() {
25         cd gdk-pixbuf && oe_runmake install
26         find ${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
27 }
28
29 do_install() {
30         :
31 }
32