Merge branch 'org.openembedded.dev' of git@git.openembedded.net:/openembedded into...
[vuplus_openembedded] / packages / gstreamer / gst-plugins-ugly_0.10.9.bb
1 require gst-plugins.inc
2 PR = "r0"
3
4 DEPENDS += "gst-plugins-base ${@get_depends(bb, d)}"
5 SRC_URI += "${@get_src_uri(bb, d)}"
6
7 def get_src_uri(bb, d):
8         if bb.data.getVar('DISTRO', d, 1) in [ 'opendreambox' ]:
9                 return ""
10         return "file://gstmad_16bit.patch;patch=1 " \
11                 "file://gstsid_autofoo_HACK.patch;patch=1"
12
13 def get_depends(bb, d):
14         if bb.data.getVar('DISTRO', d, 1) in [ 'opendreambox' ]:
15                 return ""
16         return "libsidplay"