Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / groff / groff_1.19.2.bb
1 DESCRIPTION = "GNU roff"
2 SECTION = "base"
3 LICENSE = "GPL"
4 PR = "r4"
5
6 SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
7                    file://Makefile.in.patch;patch=1 \
8                    file://Makefile.sub.patch;patch=1 \
9                    file://groff.patch;patch=1"
10
11 PARALLEL_MAKE = ""
12 # prefix and exec-prefix are broken and the .in file is broken too
13 # and can't be autoreconf'ed, so specify every dir
14 EXTRA_OECONF="--prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}/info --with-appresdir=${D}${datadir}"
15 inherit autotools
16
17 do_configure() {
18         oe_runconf
19 }
20
21 #
22 # The installer refuses to do anything if the prefix directory does not
23 # already exist, so create it manually before the standard install runs.
24 #
25 do_install_prepend() {
26         install -m 0755 -d ${D}
27 }