merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / gpe-mini-browser / gpe-mini-browser_svn.bb
1 DEFAULT_PREFERENCE = "-1"
2
3 DESCRIPTION = "A lightweight webbrowser for the GPE platform"
4 LICENSE = "GPL"
5
6 DEPENDS = "sqlite gettext gtk+ glib-2.0 osb-nrcit libgpewidget"
7 RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
8
9 PV = "0.19+svn${SRCDATE}"
10 PR = "r0"
11
12 SRC_URI = "${GPE_SVN}"
13
14 S = "${WORKDIR}/gpe-mini-browser"
15
16 inherit autotools
17
18 do_install() {
19                 install -d ${D}/usr/share/applications
20                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
21                 install -d ${D}/usr/share/pixmaps
22                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
23                 autotools_do_install
24 }
25
26 pkg_postinst_${PN}-doc () {
27         #!/bin/sh
28         if [ "x$D" != "x" ]; then
29         if [ -e /etc/gpe/gpe-help.conf ]; then
30                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
31         else
32                  echo [Help] >> /etc/gpe/gpe-help.conf
33                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
34         fi
35         if [ -x /usr/bin/gpe-helpindex ]; then
36                 echo generating help-index
37                 gpe-helpindex
38         else
39                 echo not generating index for gpe-mini-browser
40         fi
41         fi
42 }
43
44 pkg_postrm_${PN}-doc () {
45         #!/bin/sh
46         if [ -e /etc/gpe/gpe-help.conf ]; then
47                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
48                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
49         fi
50         if [ -x /usr/bin/gpe-helpindex ]; then
51                 echo generating help-index
52                 gpe-helpindex
53         else
54                 echo not generating index for gpe-mini-browser
55         fi
56 }
57