Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / gpe-bootsplash / gpe-bootsplash_1.15.bb
1 inherit gpe
2
3 DEPENDS = "gtk+ libsvg-cairo"
4 SECTION = "gpe"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 FILE_PR = "r9"
8
9 SRC_URI += "file://splash-p.svg \
10             file://splash-l.svg \
11             file://init.patch;patch=1"
12
13 FILES_${PN} += "${datadir}/gpe"
14
15 do_install_append() {
16         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
17         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
18         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
19 }
20
21 pkg_postinst() {
22
23         update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
24         update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
25 }
26
27 pkg_postrm() {
28         update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
29         update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
30 }