bb files: Revert the introduction of FILE_PR
[vuplus_openembedded] / packages / gnuradio / gnuradio_svn.bb
1 require gnuradio.inc
2
3 DEFAULT_PREFERENCE = "-1"
4
5 PV = "3.1.3+svnr${SRCREV}"
6 PR = "r4"
7
8 EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable-usrp1 --disable--usrp2"
9
10 SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
11     file://no-usrp2.patch;patch=1 \
12 #   file://no-trellis-doc.patch;patch=1 \
13 #           file://gnuradio-neon.patch;patch=1;pnum=0 \
14            "
15
16 S="${WORKDIR}/trunk"
17
18 #do_configure() {
19 #        ./bootstrap
20 #        oe_runconf
21 #}
22
23 do_compile_append() {
24         sed -i -e s:${STAGING_DIR_TARGET}::g \
25                -e s:/${TARGET_SYS}::g \
26                   gnuradio-core/gnuradio-core.pc
27 }
28