gnumeric: disable PARALLEL_MAKE close bug# 3500
[vuplus_openembedded] / packages / gnumeric / gnumeric_1.8.2.bb
1 LICENSE = "GPL"
2 SECTION = "x11/utils"
3 S = "${WORKDIR}/gnumeric-${PV}"
4 DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui orbit2-native"
5 DESCRIPTION = "Gnumeric spreadsheet for GNOME"
6
7 PR = "r1"
8
9 PARALLEL_MAKE = ""
10
11 inherit gnome flow-lossage
12
13 SRC_URI += "file://remove-docs.patch;patch=1"
14
15 EXTRA_OECONF=" --without-perl "
16
17 PACKAGES_DYNAMIC = "gnumeric-plugin-*"
18
19 FILES_${PN}-dbg += "${libdir}/gnumeric/1.8.2/plugins/*/.debug"
20 FILES_gnumeric_append = " /usr/lib/libspreadsheet-${PV}.so "
21
22 # We need native orbit-idl with target idl files. No way to say it in a clean way:
23 do_configure_append () {
24         find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
25 }
26
27 python populate_packages_prepend () {
28         gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
29
30         do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
31 }