conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / gnome / libbonobo_2.6.2.bb
1 LICENSE = "GPL"
2 PR = "r1"
3 SECTION = "x11/gnome/libs"
4 DESCRIPTION = "Bonobo CORBA interfaces library"
5 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libbonobo/2.6/libbonobo-${PV}.tar.bz2 \
6            file://gtk-doc.m4 \
7            file://gtk-doc.make"
8 DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
9 ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
10
11 FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so"
12 FILES_${PN}-dev += "${libdir}/orbit-2.0/* ${libdir}/bonobo/monikers/* \
13         ${libdir}/bonobo-2.0/samples"
14
15 inherit autotools pkgconfig
16
17 PARALLEL_MAKE = ""
18
19 do_configure_prepend() {
20         install -d m4
21         install ${WORKDIR}/gtk-doc.m4 m4/
22         install ${WORKDIR}/gtk-doc.make ./
23 }
24
25 ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
26                       bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
27                       bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
28                       bonobo-activation-server-info.h bonobo-activation-version.h"
29
30 BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
31                   bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
32                   bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
33                   bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
34                   bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
35                   bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
36                   bonobo-property-bag-client.h bonobo-shlib-factory.h  bonobo-storage.h \
37                   bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
38                   bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
39                   bonobo-app-client.h bonobo-application.h"
40
41 do_compile() {
42         oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
43 }
44
45 do_stage() {
46         install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
47         for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
48         install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
49         for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
50         install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
51         install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
52         install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
53         oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
54         oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
55 }
56
57 do_install() {
58         oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
59 }